Tidbit: VLC for Multicast Testing

Its pretty well documented on the lovely inter tubes that using VLC to stream multicast is a pretty slick way to test out a multicast setup. It’s also pretty well documented that you need to change the TTL for multicast in VLC to something other than the default 1 or 0 or whatever it is.

Okay cool, so no problem right? VLC has a pretty nifty little “wizard” to set up a stream. Click next, type a group address to use, pick a flavor (UDP or RTP), pick some transcode stuff, and last page (on OSX, also somewhere in Windows, but maybe not the last page) the magical “TTL” setting. It starts at 1. Okay great, so we already know we need to change this… so put it to 10, or 100, or whatever you want.

So cool, time to test. Start with a sender and a receiver in the same subnet just to test it out — easy money, of course that works. Okay great, so next lets move between subnets. WTF. No dice. You know you can set up PIM dense mode…. its possibly the easiest thing ever. Turns out that the little TTL thing you thought you set didn’t really do anything. At all. Nothing.

So if you take a journey to the “Preferences” page and do the “Show All” in OSX, or “Advanced” (or something of the like) in Windows, there just so happens to be a section for “Stream output.” Well in said section there’s another menu called “Access output.” In this menu, there’s ANOTHER TTL setting. So you thought you set the TTL before to 10 or something, but this one still says NOT THAT!!! GRRR!!!  Change this to whatever you need, and wham bam thank you ma’am (assuming your multicast setup is good) you’re off and streaming!

 

I’d love to link to the other blog that lead me to discover this, but I can’t seem to re-find it. So hopefully this helps somebody else out!

 

Advertisements